Image paths and tnj files

Applies to: All programs


This article describes the many methods for setting image paths when working with tnj files - either in Version 3 or Version 4. For information on setting image paths for Version 4 jobs please refer to the article Image paths in Version 4 jobs

Why use image paths?

On most occasions images are brought into the software as thumbnails (previews) at a much smaller size than the original files. When it comes time to print or export the images however, it will be necessary for the software to find the full size original files to avoid receiving a "Cannot find bitmap" error.

Importing images as previews

As mentioned above, images are normally imported into the software as lower resolution previews. (It is possible to import the full size original images instead, however this is not recommended as it slows the import and results in large, cumbersome job files.)

Importing previews is the default setting for all programs and this setting can be checked from the Image Mode>Images>Import from disk>Setup window

Figure 1: Telling the software to import previews only and remember their path

With the option to import previews checked, the user then has two further options as to how to find the images when needed.

  1. By simply remembering where the images were imported from. (Location 1 in the list below)
  2. Discarding the path meaning the software will search locations 2, 3 and 4 in the list below

Where does the software look and in what order?

Not only is it important for the user to understand how to tell the software where to look for the images but since there are many options available it is important to understand the order that the software will search these locations.

With this in mind we can list the various locations in the order the software will search them.

  1. Remebered path if the option was checked when the images were imported
  2. Any paths set in File>Options>Paths>Image files
  3. The same folder as the tnj job file
  4. In a jobname#images subfolder in the same directory as the tnj file

Location 1: Remember the path

It is possible for the software to simply remember where the images were imported from and use this location when it needs to access the original images for printing or export. While this method has the advantage of simplicity, it means however neither the job file or the images can be moved from their original location. In many cases this is not practical.

It should be stressed the software will only remember the original path to the images if the option is checked as shown in Figure 1. If using this option remember the images must never be moved from their original locations. Note however if the software cannot find the images in the original location it will contnue searching in locations 2, 3 and 4.

Location 2: Defining paths in File>Options

Image paths can be set in File>Options>Paths>image files. Paths can be entered here in many ways. In addition it is possible to enter more than one path with the software searching each location in turn until it finds the images.

Examples include:

  • Entering a path directly to the jobs images folder
  • Entering a path relative to the tnj file's location
  • Entering a path using the @+ wildcard
Entering a direct path

This method points directly to the images folder. It has the advantage of simplicity however it usually not practical (and is very tedious) to set a new path for each job in this manner.

Figure 2: Entering direct image paths

Entering a relative path

It is possible to enter a path relative to the job file's location.

For example if the job file is stored in a folder:

T:\Timestone\Job files\Job 1

and the images belonging to Job 1 are in:

T:\Timestone\Job files\Job 1\Images

then the path to the images can be entered as:

\Images

Figure 3: Entering a relative image path

Using the @+ wildcard

The method described above relies on the job file and the images being stored on the same computer and in locations realtive to each other. Some users may choose to store the images on a central image server while openning job files on another computer. In these cases (and other examples depending on the user's particular workflow) it is possible to use the @+ wildcard.

For example if the path is entered as:

\\Imageserver\Schools\@+

and the currently open job file is called Job 1, the software will search for the images in the following path:

\\Imageserver\Schools\Job 1

Figure 4: Using the @+ wildcard in a path

UNC paths

Users familiar with the Universal Naming Convention (UNC) may use UNC in any of the paths described above.

Location 3: The same folder as the tnj file

An easy location to be certain the software will know where to find the images is to simply save them in the same folder as the tnj file

Location 4: The jobname#images subfolder

A very popular method is to save the images in a jobname#images subfolder where jobname is the name of the job file. The subfolder must be in the same folder as the tnj file.

Provided the job file and the jobname#images subfolder always stay together in the same folder, the software will always know where to find the original images for printing and export.

Part of the popularity of this method comes from the fact that this subfolder is automatically created and used when shooting tethered with CapturePost and OutPost. It is also used with the "Send to lab" feature of PackBuilder and OutPost.

End of article


Recent Discussions

15 Sep, 2018 10:29 AM
11 Sep, 2018 10:52 PM
04 Sep, 2018 03:16 PM
14 Aug, 2018 02:48 PM
03 Aug, 2018 03:05 PM