Working with tnj files in Version 4

Applies to: Version 4


Version 4 continues to support and work with tnj files in many ways. With Version 4 it is possible to:

  • Work in 'tnj mode' by setting options in File>Options>Job types
  • Create, open, save and close tnj files
  • Start a new Version 4 job by importing a tnj file
  • Merge a tnj file into an existing SQL job
  • Export a tnj file from a SQL job

Job types

Broadly speaking Version 4 can work with two types of jobs:

  1. tnj files
  2. SQL jobs

The user may select which job type will be most often used in File>Options>Job types. Depending on the selection, different menu options are made available especially with regard to the File>Open and File>New commands.

Figure 1: Selecting the main job file type

Opening tnj files in Version 4

Version 4 allows the user to open tnj job files and work with them as in any previous version of the software. Working with tnj files in this manner bypasses the SQL database and settings made in the Timestone Administrator.

Import a tnj file into Version 4

It is possible to start a new job in Version 4 by importing a tnj job file. This action is performed via 'File>New from tnj file ...' and presents the user with a browse window to select the tnj file followed by the Version 4 'New Job' window where the job can be assigned a Season, Account and Offer.

Importing a tnj file into Version 4 imports all aspects of the tnj file such as

  • Fields and data
  • Images and matchinformation
  • Poses
  • Print queues
  • Order information

If the tnj file contains order information in Details Mode it must contain the package component in order to utilize any Offers/Packages defined in the Timestone Administrator. (See Ordering in Version 4).

Image subsamples will be created upon importing the tnj file. The software must therefore have access to the original images (via any of the image paths options) in order to succesfully import the job file.

Export a job as a tnj job file

Version 4 includes the capability of exporting a job as a tnj job file. It is foreseen the most common use of this feature to be in workflows with CapturePost where the job is started in Version 4 then exported to tnj file for use with CapturePost.

Merging a tnj job file into a Version 4 job

It is possible to merge a tnj file into an already present Version 4 job with the 'File>Merge ...' command. Again it is foreseen the most common use of this feature to be with CapturePost workflows. Following on from the previous example, once the photographer has finished working with CapturePost, the job file is merged back into the Version 4 job from which it originated.

End of article


Recent Discussions

18 Oct, 2018 10:18 AM
03 Oct, 2018 07:08 PM
02 Oct, 2018 04:56 AM
11 Sep, 2018 10:52 PM
04 Sep, 2018 03:16 PM